I'm encountering HTTP 500 Internal Error after installing SharePoint 2010. I ran SharePoint 2010 Central Administration at the first time and got it. I ran IISRESET but there was any changes. Also, I set CallStack="true", CustomErrors="Off" and debug="true" and then got "The handle is invalid. (Exception from HRESULT: 0x80070006 (E_HANDLE)) "

Even I configured container in Active Directory in order to track SharePoint 2010 Installation but I did not saw any changes there.

I'm using Vmware to deploy SharePoint with single-server deployment.

I installed SharePoint 2010 twice and have still gotten the error.

Thanks & Regards.

  • > HTTP 500 Internal Server Error: While opening Central Administration | > SP 2010 using Windows 7 > > I am having this error while opening Central Administration of SP 2010 > I checked the event viewer got this as the last entry........** Log Name: Microsoft-SharePoint Products-Shared/Operational Source: Microsoft-SharePoint Products-SharePoint Server Search Date: 14-02-2013 23:35:08 Event ID: 97 Task Category: Admin Audit Level: Information Keywords: User: NETWORK SERVICE Computer: Aman-PC **Description: An incremental crawl was started on 'Local SharePoint sites' by NT AUTHORITY\NETWORK SER – user14909 Feb 14 '13 at 18:26
  • Are there any errors in the application event log? – Snowburnt Nov 14 '14 at 19:20


I ran into this a while back and doing as prescribed in the following thread did the trick for me.


| improve this answer | |
  • I did Web.Config default and then got HTTP 500 Internal Error too. Thank for your reply but it did not concern exactly my problem. – Thuan Jul 26 '11 at 14:07
  • I just audited all permission and then recognized that my account, which was used to install SharePoint 2010 binaries, didn't belong to local Administrator group on SharePoint server. – Thuan Jul 26 '11 at 14:13

I just ran into this same problem. I know this is an old question but for people like me that are searching for this I want to post my solution to the problem. I tried a lot of different things to try en resolve this. I noticed that in my IIS, when I highlighted my SharePoint - 80 site and both SharePoint Central Administrator and SharePoint Web Services Sites that there was an ISAPI filter for Framework 4.0. Since SP2010 uses v2.0 I removed those filters and that did the trick.

HTTP 500 could reference to a lot of different things and I remembered that there was an error pointing to the asp v4.0 directory.

Try checking all the settings on your IIS including your ISAPI filters.

Good luck,


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.