I got a backup of a Sharepoint 2010 site that I created from our client's production server so that I can make some new changes to it on my staging server.

I can restore the site collection from the backup without a problem but when I try to create a backup of the same site on my staging server, I always get the error "Operation is not valid due to the current state of the object".

Before the error is given however, a small part of the backup file is created. If I try to run the Backup-SPSite again, it always fails at the same point and the corrupt backup files are always the same size.

Going through the logs it looks like the problem might be related to user permissions. I wonder if it's possible that the user permissions, user data, etc that came over from the client's production server are somehow screwing the backup process now because the same data cannot be found on my staging server.

The same error is mentioned here http://technet.microsoft.com/en-us/library/ee748617.aspx but UseSqlSnapshot parameter doesn't work anyway in my case.

I've been hitting my head against the wall with this problem and would appreciate if anyone has any advice on what might help! :)

The setup:

Windows Server 2008 R2

Sharepoint 2010 Server (no SP1 because it hasn't been installed on the client's production server)

Microsoft SQL Server Express Edition


2 Answers 2


The backup process started working after I checked in a file that had been checked out by a user on my client's production server.

I found out what file that was by opening the corrupted backup file and looking at the title of the last entry.


I can see two MAJOR Problems in the Setup there... No SP1 will definitely throw the exception if you export from a SP1 Sharepoint Farm and try to import into a NON-SP1 environment. Get this upgraded and also sort out the SQL Server Express Edition... Sharepoint doesn't run on SQL Express.. Not natively.. How did you get it installed in the first place?

  • SharePoint runs fine in a single server environment with SQL Server Express Edition - infact the installer installs it if SQL Server isn't already there (technet.microsoft.com/en-us/library/cc262485.aspx). Where have you read that it doesn't?
    – James Love
    Commented Jul 26, 2011 at 8:09
  • Hi James, My mistake.. I was thinking of another product... I think however it is to be used solely for running SP as a dev product on Windows 7 and not in a prod environment and definitely no on Server 2008... Might also explain the problem that the poster is experiencing since SQL Express does not support half of what SQL Server does...
    – Fox
    Commented Jul 26, 2011 at 8:33
  • Cheers guys. I upgraded the SQL Server to R2 Enterprise edition but that didn't solve the problem. See my answer above to find out what worked.
    – Juhani
    Commented Aug 3, 2011 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.