1

Recently we have patched our development farm. It is a SharePoint 2013 enterprise edition on-premise farm. After patch (product config wizard have completed successfully), when any user browse the MySite URL it always redirect to ~my site url ~/_layouts/15/start.aspx#/Person.aspx?accountname=testdomain/user1

which user1 is the login user. It is showing his user profile correctly.

Before patch, it should be redirected to:

~my site url ~/_layouts/15/start.aspx#/default.aspx

Here user can see a textarea to type in his feed and see all newsfeed posted by others. At this moment, all users cannot post Newsfeed to "Everyone" and see others' feed. However, all users can still post feed to other site collections (e.g. team site).

I tested browse to ~my site url~ with Farm Admin and he can browse correctly. So I think the patch have fixed some permission issue and then break things.

How can I fix it so that it behave same as before patch?

0
  1. Go to MySite using Admin credentials
  2. Go to MySite subpage you wish to be the default page when user arrives to MySite
  3. Take page into edit mode using Edit Page from Gear icon on top right
  4. From Ribbon, click "Set as Home Page"
  • I tried. Beside the farm admin, every user cannot visit default.aspx. They will be redirected to Person.aspx when try to browse default.aspx. I checked with F12 no 301 returned. Every entry is 200. – Mark L Jan 18 '16 at 10:13
0

End up it is permission issue. I don't know why Microsoft is giving out this option when the option will break things in weird way.

The problem is solved by follow steps:

Open Central Administration > Manage Service Applications > User Profile service application > Manage User Permissions

In the prompt up dialog, make sure the MySite users (in my farm's setup, NT AUTHORITY\authenticated account is used here) have Create Personal Site (required for personal storage, newsfeed, and followed content) checked.

I unchecked this option about half year ago to disable Mysite creation. During past few months, no user encountered problem until we patched the servers. Right after patched, users can no longer browse to ~my site url~/default.aspx.

Right after I checked the option back, users can browse now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.