1

I am working on SharePoint 2013 , and i want to be able to send emails to a document library. so i did the following on our SharePoint server:-

  1. I install the SMTP service on the SharePoint server.
  2. I configure it from the IIS.
  3. From the

"Central Administration >> System Setting >> Incoming E-Mail Settings"

I provide the following settings:-

enter image description here

  1. I started the SMTP service on the SharePoint server as follow:-

enter image description here

  1. then I created a new document library and i configure the "In-coming email" as follow:- enter image description here

now I send an email containing a word document as an attachment to the email address which have the following format "myname@OurSharePointServerName-OurDomainName", but nothing were added inside the document library .. so can anyone advise on this please ?

now after around 10 minutes of sending the email to the SharePoint list, I received the following delivery failure email:-

This message is a warning that an email you are trying to send has not yet been delivered. You do not have to do anything yet as the

email is still queued for delivery.

An email you addressed to email address :

-- *********



has not yet been delivered. The problem appears to be :

-- Recipient email address is possibly incorrect



Additional information follows :

-- Domain has no MX records or is invalid



This condition occurred after 6 attempt(s) to deliver over a period of 1 hour(s).

You will receive a rejection notice after a maximum of 4
days if the email cannot be delivered. If you sent the email to multiple
recipients you will receive one of these messages for each one which is still
undelivered, otherwise they have been sent.

Thanks

  • @TrevorSeward not sure if it is duplicate but a new question. in the previous question i was asking why the "in-coming email " settings link is missing ,, but now i configure it (since i used a supported list type) but the library is not reeving any emails... – john Gu Jan 14 '16 at 14:19
  • Edit your previous question with the additional information. – Trevor Seward Jan 14 '16 at 14:23
  • 2
    @TrevorSeward if i do so , someone might say that it is a new question ,, and i should create a new one !!! so what is the rule that govern this ? – john Gu Jan 14 '16 at 14:29
  • @TrevorSeward can you explain why you are assuming that i need to edit the original question , rather than creating a new one,, since the 2 questions are not the same !!! – john Gu Jan 14 '16 at 14:38
3

You must configure your Exchange server (or any email server you use to send emails in your organization) to route emails @OurSharePointServerName-OurDomainName to the IP address of the SharePoint server where the SMTP service is enabled.

See "Step2: Create Send and Receive Connectors in Exchange 2010" at http://blogs.msdn.com/b/pareshg/archive/2010/04/23/how-to-configure-incoming-and-outgoing-emails-in-sharepoint-server-2010.aspx.

  • thanks a lost for the helpful reply.. now i followed the same steps mentioned here technet.microsoft.com/en-us/library/cc262947.aspx#section2 and i follow the basic scenario (not the advanced scenario) and it did not mention anything about exchange server... so can you send me the required steps that need to be done from the exchange server part , so i know exactly what to say to our system admins ,,as i am not the person responsible for the exchange server.. thanks – john Gu Jan 14 '16 at 15:02
  • 1
    Edited my answer. – Evariste Jan 14 '16 at 15:27
  • thanks very much for this great help.. OK i got your point so seems we need to create a connector inside the exchange server , which basically say that any email send to "@OurSharePointServerName-OurDomainName" should be transferred to the SharePoint server (where the smtp service is installed) ,, is this correct ? second question , in this way the email will be directly transferred from the exchnage server to SMTP service inside SharePoint ,and i do not need to define a drop email since i am using the "automatic" setting mode ,, is this correct ? – john Gu Jan 14 '16 at 15:51
  • 1
    "Correct" for both your questions :) – Evariste Jan 14 '16 at 16:03
  • 1
    The "smarthost" they're referring to is nothing else than the server where the SMTP service is setup in your farm. – Evariste Jan 15 '16 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.