2

I have a SharePoint 2013 workflow that was created for us by a third party.

There is one copy of the workflow deployed on a test install of sharepoint and one in production. It is applied to a Document library in each.

The one in test has one action that reads:

Setup permission for Variable:Leader on [%CurrentItem:Encoded Absolute URL%] with Current Item:ID

See screenshot: Screenshot of production workflow

On the production workflow it reads:

Setup permission for Variable:Leader on [%CurrentItem:Encoded Absolute URL%] with Current Item: 

See screenshot: Screenshot of test server workflow

Notice on the production one the "ID" is missing (along with other columns - such as Modified By, Approval Status etc.). When I select the text "Current Item:" the ID option is not in the drop down, yet it is there for the one on my test site.

I believe this workflow may have been originally created in Visual Studio.

I've tried re-adding this action using SharePoint Designer, but the CurrentItem: ID is still not available.

Any ideas on how I can get this to match my test site?

  • Are you able to see the ID column in the production library itself? – jpollar Jan 13 '16 at 21:05
  • No. However I never see the ID column in the Library Settings page. In this case I don't see it in my test site or my production site. However I know the ID is working because I can browse to various documents in my Library using the ID in the url - such like... intranet/Policies/workspace/Documents/Forms/EditForm.aspx?ID=99 – Maureen Jan 14 '16 at 11:07
  • Right..but you should be able to add it to the view and see it. What are you trying to modify the workflow with, SPD? – jpollar Jan 14 '16 at 15:53
  • Yes, I'm using SPD to modify the workflow. I don't believe this has anything to do with a list "view". I am not able to add an ID column under Library settings. – Maureen Jan 18 '16 at 14:26
  • I just wanted to make sure the list wasn't corrupted or something. If you're able to add and see ID in a view, it's there. Just have to figure out why it's not showing in SPD. You won't see ID in the library settings. It's an internal field. – jpollar Jan 18 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.