28

Is anyone here experience problems in SharePoint after installing the latest JAN 2016 on 13th Jan 2016 (Western Australian Time) updates for SharePoint 2013. I am guessing it could be KB3114503 update giving me problems.

I am getting the same problem on other machines after running the same updates too.

The problem I am receiving is, on every list view I get this error message below:

TypeError: Unable to get property 'replace' of undefined or null reference  
TypeError: Unable to get property 'replace' of undefined or null referenceSys.ArgumentNullException: Sys.ArgumentNullException: Value cannot be null. Parameter name: element 
  • I couldn't find anything from one of the SP updates engineer blog: blogs.technet.microsoft.com/stefan_gossner/2016/01/12/… Or Todd Klindt: toddklindt.com/blog/Regressions/sp2013Jan2016cu.aspx – Christoffer Jan 13 '16 at 15:37
  • You should report it to Microsoft, or try to contact Stefan Grossner from the first blog with your issue. – Christoffer Jan 13 '16 at 15:39
  • Same errors here. This update breaks Sharepoint. There is no uninstall. – user50239 Jan 13 '16 at 16:23
  • I'm facing the the same issue. However I can add a new list that is doing OK. Unfortunately the particular update cannot be uninstalled. Guess I'll have to try to get the system back from tape .. BR Thomas – user50240 Jan 13 '16 at 16:32
  • I can save with no issues, just after save and view the list the error appears. – csharpguy76 Jan 13 '16 at 17:30
17

Apply the Cumulative Update for SharePoint 2013 (Foundation, Server, or Project). This should resolve the issue. This appears to be caused from applying MS16-004 while having a previous Cumulative Update installed.

Cannot reproduce from a system upgraded to the SharePoint Server 2013 Jan 2016 CU, but can reproduce on another farm by only upgrading to MS16-004 with Sept 2015 CU applied.

EDIT: Stefan Goßner has also indicated it can be resolved by installing hotfix KB3114508, also released on Tuesday 01/12/16.

  • 2
    Trevor Seward thanks this help solved the problem. All list view are back to normal. – csharpguy76 Jan 14 '16 at 5:45
  • Same here. Thanks! I keep forgetting CUs need to be installed manually and include additional fixes that Automatic Updates doesn't always deliver. – underscore_d Jan 14 '16 at 11:11
  • 1
    The hotfix KB3114508 mentioned by Stefan Goßner fixed this issue for us. – user50390 Jan 18 '16 at 17:54
  • 1
    The hotfix KB3114508 worked for us as well. Thanks. – Piyush Jan 20 '16 at 8:21
  • @Trevor now is there any prerequisites for installing the "KB3114508" ? now the latest updates done on our sharepoint farm was on November 2015,, and i do not want to apply additional updates for the time being as we have many tasks to do,, so is it safe if i install the KB3114508 ? even if i do not have the latest updates ?? – john Gu Jan 27 '16 at 14:11
3

We installed MS16-004 w/ KB3114503. Our error occurs on list items, and is often showing this "TypeError: b is undefinedTypeError: b is undefined...". We found that if the view was modified from "Item Text (linked to item with edit menu)" to "Item Text (linked to item)" the error would disappear and the user could see the list.

Not a complete fix, but could help someone seeing similar errors...

  • i am facing this problem also "TypeError: Unable to get property 'replace' of undefined or null referenceTypeError ..nable to get property 'replace' of undefined or null referenceTypeError" and i chnage the column from title linked to edit menu to title linked to item , it will work ... – john Gu Jan 22 '16 at 3:05
0

As a best practice, You have to wait to apply the CU, never rush into the installation. You have to install into the dev farm and then perform the testing. Once you sure that it is success then go for the production.

Did you apply the server CU or foundation? is it completed successfully( installation and config wizard)? are you getting this error on all sites or few?

As a workaround Mentioned in this post, try to open the site in IE compatibility view.

Also, try contact MSFT about this.

  • The updates was installed on my work and home dev box. For work I can get the administrators to restore one of the VM backups. But for home unfortunately I have to re-create my VM again. – csharpguy76 Jan 13 '16 at 17:31
  • The post you provided doesn't fix the problem. But thanks for the help. – csharpguy76 Jan 13 '16 at 17:40
  • The question is about KB not a CU, the issue is resolved by appying a CU though! – Robert Lindgren Jan 14 '16 at 8:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.