2

When activating the "SharePoint Server Publishing Infrastructure" site collection feature I am receiving the following error message

"A duplicate content type name "Page" was found"

I am activating the feature from the SharePoint UI so I went to Site Settings>Site Collection Administration>Site collection features.

Has anyone already experienced this problem? What can be the cause?

I am currently working with SharePoint 2010.

0

looks like you have duplicate content Type Name Pages, You have to delete it in order to activate the feature. check this one http://vivek-soni.blogspot.com/2010/07/duplicate-name-error-while-creating.html

0

Please use the solution mentioned in the below question. Even though it refers to SharePoint online still it works in 2010/2013 versions as well.

Error in activating Publishing feature in SharePoint Online

Basically it uses Powershell commands to activate the feature and you may also use STSADM commands to get the same behavior.

Root Cause:

There are situations where we tend to use different content types but those may be referred to same parent content type. In some situations, deleting those can be a problematic since they might be in use already or create additional problems with the content already have inheritance. In those cases, it is better to activate by force via Powershell or STSADM commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.