3

I created a 2013 workflow in SharePoint Designer which causes news articles to unstick themselves from the top of the news list after 2 minutes (for testing purposes), but I am seeing this error when I try to execute the workflow manually:

    RequestorId: a5534244-6636-521a-1a6f-ccc38dcd5b70. 
    Details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],
    "X-SharePointHealthScore":["0"],
    "SPClientServiceRequestDuration":["91"],
    "SPRequestGuid":["4e299c94-d879-4b0f-a1de-4dd9d0650e9a"],
    "request-id":["4e299c94-d879-4b0f-a1de-4dd9d0650e9a"],
    "X-FRAME-OPTIONS":["SAMEORIGIN"],
    "MicrosoftSharePointTeamServices":["15.0.0.4551"],
    "X-Content-Type-Options":["nosniff"],
    "X-MS-InvokeApp":["1; RequireReadOnly"],
    "Cache-Control":["max-age=0, private"],
    "Date":["Tue, 12 Jan 2016 09:45:35 GMT"],
    "Server":["Microsoft-IIS\/7.5"],
    "X-AspNet-Version":["4.0.30319"],
    "X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, 
    ActivityExecutor executor, 
    BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, 
    BookmarkManager bookmarkManager, 
    Location resultLocation) 

I have no idea where to start with this, so would appreciate if anyone could point me in the right direction.

This message becomes available about a minute after starting the Workflow, at which point the Workflow's status is changed to "Cancelled".

I have tried resetting our SharePoint server, but without any luck. The workflow is as follows:

Stage 1
    Add 0 Months, 0 days, 0 hours, 2 minutes to Today (Output to Variable: date)
    If Current Item: Promote Article equals Yes
            Pause until Variable: Date
            Then Check out item in Current Item
            Then Update item in Current Item (Promote Article = no)
            Then check in item in Current Item
    Go to End of Workflow

Does anyone have any suggestions as to how I can start debugging this?

  • What do you see, when you try to see the status of the workflow.? do you get "Sorry, you don’t have access to this page." message.? – Karthik Jaganathan Jan 12 '16 at 11:40
  • Hi Karthik, I updated my answer. The Workflow is cancelled after about a minute each time, at which stage I can see the error. – Bassie Jan 12 '16 at 12:09
  • This has been raised with out suppliers and I will post here once we have had some feedback – Bassie Jan 13 '16 at 14:02
2

After researching this error, I noticed there was no simple solution. Each person solved the errors in different ways. I have mentioned every solution I found. The easiest solutions are listed first.

Solution 1:

The new changes to the SharePoint 2013 workflow, there was also changes made to which account is used to write logs to the Workflow History list. In 2010 the system admin account was used but in 2013 the workflow initiator’s account is used. This account needs to have at least contribute permissions to the Workflow History list (a hidden list that can be accessed through SP Designer). So here’s the solution:

  1. Navigate to the site that the workflow is on in SharePoint 2013 Designer.

  2. Go to All Files -> Lists

  3. Right click on Workflow History

  4. Select Properties

  5. Click on Permissions for this list under the ‘Customization’ section (This should open up the edit permissions page in the browser)

  6. Break inheritance on this list by selecting Stop Inheriting Permissions in the new opened browser window

  7. Use the check box next to the appropriate group (probably the visitors group) to select the group that needs to be updated permissions

  8. Select Edit User Permissions

  9. Grant the group ‘Contribute’ permissions

  10. Select OK

Rest other solutions:

1.) The workflow initiator should have edit permissions(contribute) on the list.

2.) The workflow initiator should have a user profile.

a. Navigate to Central Administration -> Application Management -> Select the User Profile Service -> Select manage User Profiles -> Search for your account -> if an account is found you should be fine

3.) Make sure you are not creating/starting the workflow as the SharePoint Setup/Install account or a System Account

4.) User Profile Service Application is running

5.) You are able to complete a full synchronization of the User Profile Service

a. Make sure the User Profile Synchronization Account has replicate directory changes in Active Directory

6.) Last but not least is an IIS reset

a. An IIS reset will drop existing connections to your web server for a few seconds. It is recommended to do this during non-business hours.

For more information, please have a look at the below links,

  1. https://social.technet.microsoft.com/Forums/sharepoint/en-US/653dcf25-131e-402a-9fd1-f0b3e60e7750/suspended-workflow-in-sharepoint-2013-with-http-401-error?forum=sharepointadmin

  2. http://www.sharepoint4developers.net/en-nz/post/sp2013-workflows-suspended-state.aspx

| improve this answer | |
  • Hi Karthik, thanks for your detailed reply. We have reset the IIS client, and I have all the necessary permissions, as I can edit and contribute to anything on the site. Will check the user sync now – Bassie Jan 12 '16 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.