6

My problem seems to be simple, but it makes me crazy… In general I would like to display user photo from my local AD in SharePoint online (Office 365 E3).

I have asked this question on MS support, still no clear solution.

It seems that there's a problem. Below steps which I have done and what results I get:

  1. I have created new user in our on premise AD and added user photo to the user account.
  2. I can see at this moment that user photo appears in: “Skype for business”, “user account in Office 2013 local installation”, “New Power BI”, “user in local Outlook client ”
  3. OWA do not present photo, also there’s no photo in People.
  4. In SharePoint user profile service I can see
    • Picture Placeholder State: 1
    • Picture Exchange Sync State: 1
  5. I done following procedure: go to about me > click avatar > Change photos > Change your photos in Edit Details.
  6. After I complete the procedure user photo didn’t appear in SharePoint or Delve.

I read different stories and it seems that there’s problems with photo sync. It seems that user must do something/ somewhere to start sync process.

Do you have any suggestion?

-2

Try Update-SPProfilePhotoStore https://technet.microsoft.com/en-us/library/ff607547.aspx


EDIT

Go to SharePoint Online User Profiles administration interface. Click Manage User Profiles and find some user. Check picture url (right click properties). URL must contains this "User%20Photos/Profile%20Pictures" in url. That means that image is created and updated in SP User Photos library.

  • Base on Technet: The Update-SPProfilePhotoStore cmdlet should be used only after an upgrade from Office SharePoint Server 2007 has completed And I run SharePoint online, there's no upgrade process or something like this – Tomasz Szulczewski Jan 12 '16 at 9:58
  • 2
    There is no Central Admin in SharePoint Online – Robert Lindgren Jan 12 '16 at 10:20
  • Then it is User Profiles administration – Marko Tica Jan 12 '16 at 10:26
  • There is user profile in SharePoint admin center. But there's no picture URL. There is "Picture" properties which give me possibility to upload photo, but this is not the case as it should be taken from user account. But I found that there are just a few users with pictures. I don't know how it's possible. I am starting to think that there's something wrong on Microsoft side... – Tomasz Szulczewski Jan 12 '16 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.