1

We have a SharePoint 2013 intranet portal. When I try to reset the search index it times out. Someone have asked the same question here 2013 Content Index Reset Timeout

and it seems this solution works

http://bit.ly/1UKRzDe and http://bit.ly/1RjaXcr

Basically the solution is to delete the XML files from this location ProgramData\Microsoft\SharePoint\Config and then rebuild the search index...

I haven't tried this yet... but is this the officially recommended approach to troubleshoot and fix search index reset issue?

1

You can delete config cache XML files. This is standard procedure when OWSTIMER hang out, incremental/full crawl is running endlessly, HDD space is under 2xRAM and so on.

Link from blogs.msdn http://blogs.msdn.com/b/josrod/archive/2007/12/12/clear-the-sharepoint-configuration-cache-for-timer-job-and-psconfig-errors.aspx

  • this article was written on 2007... is it still relevant – Kannan Jan 13 '16 at 3:44
  • This is still relevant. I used this clear config cache in SP2013 when crawl hang out because of little free space on hdd (when hdd free space is below 2xRAM memory, sometimes crawl get stuck because of owstimer error). – Marko Tica Jan 13 '16 at 8:22
  • Thanks eVT. it fixed the issue.... but led to another set of issue which I'll post as another question. Btw, do you know how rebuilding the index fix this? – Kannan Jan 25 '16 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.