I want to create the external content type using stored procedure but it is giving me error such that, when I right click on routines in Data Source Explorer and then select New Read Item Operation then it is giving error as

"Invalid Object Name"

Why does that happen so? Whereas some of the routines, stored procedures are connecting successfully. It is creating problem due to the schema which is dbo.Information. Whereas it is hawing the name as "Information" in SharePoint Designer 2013. Stuck to the issue, unable to get, how to handle it.

1 Answer 1


Actually the problem is solved there was problem with name of the database table name in the stored procedure. Just passed name dw.TimeSheet_FK which was database table name instead of dbo.information, the problem was solved then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.