i have followed theses steps in this page t to setup Federated Search with Bing Serach on MS SharePoint 2010 i did all steps but when i do search Federated Search Web part didn't appear , why i don't get any result ?

1 Answer 1


Big Omar,

  • Is your federated search webpart on the page when you edit the page?
  • Did you select the right search location?

if you can answer both answers with true, the following can be the case:

federated searches are done server side: the server executes the search and returns the answers in the webpart. In some environments (such at the company I work), all internet traffic is trimmed: only some "white listed" addresses may be visited from the server. As the search request is handled as a visit outside that white list, no results are returned. That's why no results show up.

so: can you verify that the webparts are available, the right location is configured, that the used search location + searchterms are configured right in the central admin? after that: ask your administrator to visit bing.com from the webfrontends or the central admin. If that's possible, make sure that (I think!, it may be the search query account too, but not sure about that.) the application pool account of your app has the permissions to visit that site.

of course it can be some proxy settings too, server side. Last thing to try is to add some jquery to your page and try to fetch some data. Check if that works.

  • well thanks for this clarification but i believe there is a problem with bing connector itself i tried using yahoo one and it worked without any problem
    – BigOmar
    Jul 24, 2011 at 21:56
  • hmm strange. It's possible, though, because I believe that the connectors are quite out of date ;)
    – Bas Lijten
    Jul 25, 2011 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.