8

When I navigate to a site in SharePoint the menu link highlights to let me know which site im on, which is great

enter image description here

But when I click on documents in the management site the top link jumps to home, I want it to stay on Management because my users are getting confused where they are

enter image description here

  • It looks like your library is on Home Site, so Home link is active. The best approach would be to create Libraries under the right Site. – Gintas K Jul 18 '16 at 15:52
0

I figured this out by doing the following testing.

Created two sites "Parent Site" and "Sub Site"

This happens when you have your global navigation set to show sub sites automatically and then go to the sub site and choose inherit navigation from parent for the top / global navigation.

Therefore unchecking the "show subsites" box on the parent site will remove the automatically generated sub site links in your top navigation, however you can manually add the link to the global navigation though the structural navigation settings section of the parent site to get the desired result.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.