0

New workflow created.

To: field assigned to me

Subject: typed in manually

In the body I choose via the add or change lookup a text field and receive the error.

A workflow lookup cannot be copied and pasted from one email message to another. You should create a new lookups (click Add or Change Lookup), and delete the lookups that were copied and pasted.

The 3 fields I am trying to lookup are 1 single line of text, and 2 multi lines of text. all three fields will give me the same error. No copying and pasting when trying to get these three to stick. I can place plain text and other fields in the email body with no issue, however these three fields cause the same error

1

Certain special characters in column names cause this error in the workflow, and the solution is to replace the sign with a comparable word.

In Pascal's example, the special character was &. In my case, I had a column name containing the > sign. After changing the sign to a word (Over), the system stops returning the error.

0

You can test in another list using the same 3 fields to compare the result. Make sure you add the lookups one by one. Then provide the screenshot of how you define the email message like the below:

enter image description here

0

I get the same error and I can't solve it completely. There are very few hits on Google too...

What I am trying to do is :

-send an automated e-mail to a series of recipients whenever someone answers a survey - use lookup to quote the respondent's survey answers in the body of the email

I get this error even though I didn't copy/paste anything and used the "Add or Change Lookup" as intended.

I have however found out that I only get the error when i try to insert specific fields of the survey in the automated e-mail.

Username fields and free input fields are OK, but answers to multiple-choice questions trigger the error.

The only workarounds I can think of are: - changing the question types in the survey - pasting a link to the survey in the body of the email, and asking the recipient to check the answers from the link (as opposed to including the answers in the body of the email).

I still wish I could find a better fix.

0

Just check if you have an "and" sign like this &, in one of your columns name. if yes just replace & by and.

it fixed the problem on my side

-1

You could save those fields in a workflow variable and use it (workflow variables) in Email.

  • 1
    Can you please add an example or a brief description about the potential solution you have suggested. – Asad Refai Apr 4 '17 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.