2

I have a promoted links Webpart on a page and I've configured permissions so that only certain groups can view it. However, users who are not granted access to the webpart can see a message from the webpart that reads "The list is empty. Add tiles from the All Promoted Links view". I'd like to remove this because it's misleading to the user who doesn't need to see the webpart at all.

I'm using Foundation 2013 so I can't use audience targeting to control the content.

How else can I remove this message? CSS?

Thanks in advance.

2

One option could be to use script on the page. You can add a script editor and then use javascript/jquery to target all or a portion of the text you see on the page and hide it or change it to something else.

If for example the text you see in a SPAN then you could use JQuery like this:

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>
$( document ).ready(function() {
    $("span:contains('The list is empty')").last().hide();
}});
</script>

Since you are on-premises, another option could be to look into a project like the "SharePoint Web Part Visibility Filter Web Part". I've used this in the past but am not sure if it works with 2013. More information here: http://spvisibilityfilter.codeplex.com/

  • Thanks for the input. Just a quick newbie question. Do I need to reference jQuery within the content editor web part or am I good to straight copy/paste that code? Added it to a script editor but it didn't quite do the trick. – Alexander Edwards Dec 28 '15 at 19:09
  • What I posted is a snippet of code so it won't work by itself. I don't have the actual HTML for your page otherwise I would have added a bit more detail. I'll amend the code above but you'll need to adjust it for your actual HTML. – Erik Perez Dec 28 '15 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.