7

I have an application on SharePoint 2013. The main application has anonymous access and extended application is available only on intranet.

Both application have Windows Authentication enabled. I want to disable all kind of authentications on public version as editing will only be performed from the extended application.

I tried to disable windows authentication but I am unable to until I provide an alternate method. Please advise a simple and straightforward way to achieve this.

Thank you everyone for your awesome contributions.

  • I think you can solve this problem by change setting via IIS manager and do the changes in authentication component – Michał Dem Dec 27 '15 at 17:44
  • Setting authentication methods in IIS is not supported. Anonymous must be enabled for SharePoint Web Applications [when using any form of Claims]. – Trevor Seward Dec 27 '15 at 21:04
4

You need to turn off Windows Auth on the Zone where you have Anonymous enabled. That will prevent users from attempting to authenticate to the site when browsing anonymously. This is done via Central Administration -> Manage Web Applications -> highlight the Web App, click on Authentication, find your Anonymous-enabled Zone, and then disable Windows Auth (or other forms of authentication).

  • It says you must have at-least one authentication method selected. What should I select if I deselect windows authentication? – Sohail Ahmed Dec 27 '15 at 21:16
  • You just need to validate a single zone has Windows auth enabled. That will be the zone SharePoint Search crawls. Typically what I would do is leave the Default Zone with Windows Auth enabled, then extend the Web App and enable Anonymous there. – Trevor Seward Dec 27 '15 at 21:25
  • My scenario: Main application has both windows auth and anonymous access. Extended app has only windows auth and its hostname only accessible within domain. When I deselect windows auth from main application, it says you must select at-least one authentication method. What should I do in this case? I want to make this main application for the public to view it but not able to edit even if someone knows the password. This is required by a ministry. – Sohail Ahmed Dec 28 '15 at 9:13
  • For now I added this URL Rewrite rule: /_layouts/.*.aspx.* redirect to homepage. Please advise if this can create any issue later. – Sohail Ahmed Dec 28 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.