Is there a easy way to disable the Follow Button across the Farm using Powershell.(This request is for SharePoint 2013)

I am trying to do the same through DocAve - Policy Enforcer but it doesn't seem to be working.

Thank You


This script goes through the hierarchy and disables the Following Content feature in every WebSite. You get an error message for every site where the feature is not active or missing. This can be ignored

$w = Get-SPWeb http://MySharePointURL | ForEach{ $_.URL }
Get-SPFeature -Web $w |%{ Disable-SPFeature -Identity "FollowingContent" -URL $w -Confirm:$false}

Source: Deactivate social feature MySite, Newsfeed, OneDrive, Sync, Share & Follow in SharePoint 2013

  • can the MySharePointURl be a WebApp URL because when I put the WebApp url it only does for th Root WeSite and not for subsites under it ForEx - my webapp is sp13.bla.com and I have other site collection starting with sp13.bla.com/sites/fin and sp13.bla.com /teams/hr how do I make it happen under the subsites deep down under the sitecollection .I have around 90 SiteCollections and thousand of SubSites under it. – SavantProdigy Dec 28 '15 at 22:24
  • @SavantProdigy Not really. You need to use the mysite host URL, since the follow feature lives in all mysite instances... – Benny Skogberg Dec 28 '15 at 22:29
  • now my mysites looks like this mysite.bla.com:8080 I tried that in the above powerhsell no change? – SavantProdigy Dec 28 '15 at 22:35
  • Just an FYI I am trying to disable the Follow button on the extreme right top corner side of the SharPoint Page sorry if I was not clear on my explanation – SavantProdigy Dec 28 '15 at 22:40
  • @SavantProdigy Have you read the link? (No worries) :) – Benny Skogberg Dec 28 '15 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.