I am using the search results webpart to return a list of people in a particular department. I set up the query correctly for the webpart and when I do "Test Query", it returns 8 relevant results in the "Search Result Preview" box.

However, when I apply the query with the "Show ranked results" checked under the Settings tab, I only get back 7 people, not 8. Doing a global search also shows up 8 results.

Any ideas on why it is leaving off the 8th person? I have 30 as the setting for "Number of results per page"


2 Answers 2


The answer provided by Justas is correct. The issue I was having was that the 8th person was being removed as a duplicate. The option for "Don't remove duplicates" has been removed in SharePoint 2013 though. The web part needs to be exported and modified directly.

The solution is described by the following article: http://blogs.perficient.com/microsoft/2013/04/sharepoint-2013-search-not-display-all-results/

The steps are:

  1. Export the web part to your computer. Click on the drop-down for the web part, the 4th option is to export it.
  2. Open the file and search for "TrimDuplicates". Change the option from true to false.
  3. Save the file.
  4. Go back to SharePoint and edit the page.
  5. Click on Insert and then Web Part.
  6. Under the Categories section, there will be an option to "Upload a Web Part".
  7. Upload the web part from step #3.
  8. Go back to step #5 and select the web part you just uploaded.

It might be "Trim Duplicates" functionality interfering, which tries to remove results, which are essentially the same. Not exactly sure how it can happen with People Search, but it's wroth a try. Try disabling this by configuring Search Results web part. Instructions for SharePoint 2013: Edit Page, Edit Search Results web part, click Change Query, go to Settings tab, Select "Don't remove duplicates"

  • 2
    I went to the Settings tab of the Build Your Query, and I don't have the option for "Don't remove duplicates". The only options I have are: Query Rules, URL Rewriting, and Loading Behavior Commented Dec 22, 2015 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.