I have a web application where I am trying to use audience targeting on some Content Editor Web Parts in the root web. However, the 'Target Audiences' option is nowhere to be seen in the 'Advanced' section of the web part properties in Modify Shared Web Part.

I'm confused because another web application that I have running on exactly the same box has the 'Target Audiences' option available. What could be different between the two web applications that is hiding the target audiences option?

I've looked at both of these questions: No Audience Targeting Option and “Target Audiences” property not visible in web part tool pane but neither helps in this case.

2 Answers 2


It seems as this was an Alternate Access Mappings issue. In the logs I found errors along the lines of:

A request was made for a URL, https://domain.com:449, which has not been configured in Alternate Access Mappings.

I added this mapping, and the audience targeting is now back.


I suggest you check if both site collection got the "SharePoint Server Publishing Infrastructure" feature activated. You need this feature to enable 'Target Audiences'.

You can check the status of the site collection features by clicking: Site actions -> Site settings -> Site collection features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.