2

Sharepoint 2010 Enterprise - I have a web part which displays notifications from a list which have the ShowMe flag set to TRUE.

Although I have Enable Asynchronous Automatic Refresh checked and the Refresh Interval set at 300 (seconds= 5 minutes), when I make changes to the list item that's showing (on another PC), the results are not shown automatically on PC's that are displaying the page.

What am I doing wrong? Isn't that what Enable Asynchronous Automatic Refresh means?

  • 1
    If you open the dev tools on your browser and look at the network tab, are you seeing new requests being sent every 5 minutes? Is the view on this web part configured to be filtered as you expect so when the change does occur, it should be added or removed? – Eric Alexander Dec 15 '15 at 21:26
  • Eric, I shall check the dev tools, but, to clarify - I'm not changing the ShowMe flag, rather the content of the multi-line field which is displayed. -- So I don't expect a refresh to make the web part disappear, but I do expect a change in the content to be reflected. – George Winters Dec 15 '15 at 21:29
  • That's what I was getting at, I assumed you were toggling the ShowMe flag to show/hide content and the expectation was content should disappear, but if the view isn't configured to filter those out, it might not be apparent that it was working. In that case if it is making the network requests, it might be web part caching. Try doing a hard reload of the page and/or opening the page in a private tab of the browser. – Eric Alexander Dec 15 '15 at 21:46
2

Just to be sure that you are not running into a cache issue.

Did you reload the page on the other PC to be sure that the web part is reloaded with the Automatic Refresh Options?

From my point of view, you are doing it right.

| improve this answer | |
0

Thank you for all your insights and suggestions.

The web part is now behaving properly. I believe the answer was that I hadn't checked the page back in. D'oh!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.