3

I added a sharepoint list on a different page, but the search box for the list does not appear.

6

Edit the page > edit the list web part settings by checking the checkbox and select "edit webpart" from the dropdown menu.

Look under the tab "miscellaneous", there should be a checkbox to toggle show/hide for the list search box.

enter image description here

Or if you are using a different style for the list view, that might be the problem as some of the styles are pure OOTB styles from SharePoint 2010. If so, the search box won't be available with that certain style.

  • I'm using Sharepoint 2013, and I cannot see the list web part settings... – astropringles Dec 15 '15 at 14:53
  • @astropringles see my updated answer, make sure you edit the actual page where the list resides and edit that specific lists settings. – Christoffer Dec 15 '15 at 15:10
  • @Christoffer what would involve in adding the searchbox to the Basic Table style view in SP2013? – Bucki Oct 25 '17 at 13:47
  • @Bucki Any specific reason that you wanna use the Basic Table style? Some of the liststyles are old, and the one you mention were created for SharePoint 2010. All listviews are rendered using CSR, and the list searchbox did not exist in SharePoint 2010. – Christoffer Oct 25 '17 at 14:31
  • @Christoffer hmm basic table is old ?? It looks better as it stretches the data across the page and makes it stand out better - if you get me. Downside is any other views gets rid of the search box :( – Bucki Oct 30 '17 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.