11

I am developing a provider hosted SharePoint app part. I have defined some custom properties for the app part. I am testing the app in a SharePoint online tenant.

On a developer site when I edit the app part the custom properties section comes up.

However for the same tenant, in a Team site when I edit the web part the custom properties section does not come up.

This is the relevant part of my Elements.xml file for the app aprt

<!-- Define properties in the Properties element.
     Remember to put Property Name on the Src attribute of the Content element above. -->
<Properties>
  <Property Name="challengeid" Type="string" RequiresDesignerPermission="true" DefaultValue="challengeid" WebBrowsable="true" WebDisplayName="challengeid" WebDescription="Challenge web properties" WebCategory="Challenge web properties" />
</Properties>

Has anybody faced a similar problem and would be able to suggest a solution?

Does my online tenant needs some configuration setting?

  • Have you tried changing RequiresDesignerPermission to false? Have you also tried checking the property while under a user with Site Collection Administrator permissions to rule out permissions in general? – m1g Dec 22 '15 at 2:46
1

Change RequiresDesignerPermission to false.

<Property Name="challengeid" Type="string" RequiresDesignerPermission="false" DefaultValue="challengeid" WebBrowsable="true" WebDisplayName="challengeid" WebDescription="Challenge web properties" WebCategory="Challenge web properties" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.