I have inherited an application in which the Developer created a bunch of application pages (ASPX) which get deployed to the _layouts folder. The user is directed to these pages throughout the application like so:


However, not all users can access this. When we moved to UAT, users receive the following

403 forbidden

The only fix I have found is to give Everyone 'Full Control' on the Site in IIS. I don't think this is acceptable change for our Production environment.Is this an issue I can fix during deployment instead of making a manual change to Permissions? If not, will converting these Application pages to Visual Web Parts (ASCX) resolve the issue?


I think you have, by some reason, wrong permission setup on C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\ folder (I guess it is what you are referring "Site in IIS").

I checked my SharePoint farm. WSS_ADMIN_WPG, WSS_WPG and machine/users etc have been granted access. You may compare your permission setup with Account permissions and security settings in SharePoint 2013.

For example, WSS_ADMIN_WPG would have modify permission on %COMMONPROGRAMFILES%Microsoft Shared\Web Server Extensions\15

  • They all have access but which level? Full Control? Read / Write / Modify? It's funny because it works intermittently which would mean it may be hitting the other WFEs with different permissions – Michael Colbs Dec 15 '15 at 18:24
  • The link I quoted have mentioned their permission level needed. Notice I am talking about the NTFS permission on the WFE server not SharePoint permission. If you have a working WFE, you may just compare the permission setup on those folders. – Mark L Dec 16 '15 at 1:05

Can you tell which versión of SharePoint do you have?

Quick answer, do these users have restricted access?? This configuración could make that pages not to be reached.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.