1

When I update my workflow in SPD 2010 and save it and then push publish, the workflow does not run according to the change. I think there is an older version somewhere that is cached.

One clue to this is that I've renamed the workflow, but the new name does not appear anywhere in the web interface.

Another test was I changed so the first task was to update a simple text field - and this never gets updated, although the Workflow shows as Completed and there are no errors in the workflow history.

The last time this happened I had to delete it and rebuild it.

How do I "clear" the cache?

I've tried emptying the asp.net cache, and I've tried ipconfig /flushdns.

1

Okay, I think I got it using info from this post. That post has the path for Sharepoint in XP, but if you need the cache path for Windows 7, here it is:

%System Drive%\Users\%user%\AppData\Local\Microsoft\WebsiteCache

Here's what to do:

  1. First close out of Sharepoint Designer.
  2. Delete the entire WebsiteCache folder on your workstation (not the server). Don't worry, Windows will build a new one.
  3. Restart Sharepoint Designer and publish your workflow again.

Now it should be clear and will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.