1

I am running SharePoint 2013. We use Exchange Online for e-mail. Because we have this set to require SSL, and SharePoint won't send mail with SSL, I have a local SMTP relay set up on the SharePoint server. This simply grabs mails from the "Pickup" directory, then shoots the mail to Exchange Online with the proper credentials for the account. This works fine for page change alerts, workflow task assignments, etc.

My issue is with SSRS Subscriptions. I have SSRS installed in SharePoint Integrated Mode, and everything works except subscriptions sent by e-mail. Whenever a subscription runs, I get the error:

Failure sending mail: The specified string is not in the form required for an e-mail address.Mail will not be resent.

I have tried tweaking just about every parameter (most of which can only be changed via PowerShell), and I seem to get the same error message.

Does anyone have SSRS mail subscriptions working through a local SMTP relay? If so, would you mind sharing your settings?

Parameter definitions are here: https://msdn.microsoft.com/en-us/library/ms157273(v=sql.110).aspx

Here are some of the ones that I was tinkering with:

SMTPServerPickupDirectory - specified the folder here.

SendUsing - A value of "1" means to use a local pickup directory

SMTPAuthenticate - "0" means no authentication - which I want, since my local relay uses anonymous authentication (which then adds authentication to go out to Exchange Online)

SendEmailToUserAlias - "False" indicates that any mail address can be specified.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.