4

We have a SharePoint on-prem 2013 farm with 2 app, 2 WFE, 2 search and 2 SQL servers.

We recently updated a display template and added a new Content Search web part. While we can see that new changes with display template are applied on the server, they are not visible if I log on via a browser from a client machine, and this this is displayed in the web part from the client machine:

Display Error: The display template had an error. You can correct it by fixing the template or by changing the display template used in either the Web Part properties or Result Types.

All files for display template are residing in /_catalogs/masterpage/, and we have triple checked it for errors, and can not find any. It works perfectly fine when logging on from server, but not from outside the server.

Any ideas what this can be ?

Edit: This is the display template

<html xmlns:mso="urn:schemas-microsoft-com:office:office" xmlns:msdt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882">
<head>
    <title>xxx_Control_List_Technical</title>
    <!--[if gte mso 9]><xml>
    <mso:CustomDocumentProperties>
    <mso:TemplateHidden msdt:dt="string">0</mso:TemplateHidden>
    <mso:MasterPageDescription msdt:dt="string">This is the default Control Display Template that will list the items. It does not allow the user to page through items.</mso:MasterPageDescription>
    <mso:ContentTypeId msdt:dt="string">0x0101002039C03B61C64ED4A07F5DTYTRJ385106601</mso:ContentTypeId>
    <mso:TargetControlType msdt:dt="string">;#Content Web Parts;#</mso:TargetControlType>
    <mso:HtmlDesignAssociated msdt:dt="string">1</mso:HtmlDesignAssociated>
    <mso:CrawlerXSLFile msdt:dt="string"></mso:CrawlerXSLFile>
    <mso:HtmlDesignPreviewUrl msdt:dt="string"></mso:HtmlDesignPreviewUrl>
    <mso:HtmlDesignConversionSucceeded msdt:dt="string">True</mso:HtmlDesignConversionSucceeded>
    <mso:HtmlDesignStatusAndPreview msdt:dt="string">https://xxx.sss.net/ie/_catalogs/masterpage/Display Templates/xxx/Content/xxx_Control_List_Technical.html, Conversion successful.    </mso:HtmlDesignStatusAndPreview></mso:CustomDocumentProperties>
    </xml><![endif]-->
</head>
<body>
    <div id="Control_List">
        <!--#_
            ctx.xxx = ctx.xxx || {}
            ctx.xxx.listTitleResource = "TextTechnical"
            ctx.xxx.listIcon = "icon-Icon_Pitch"
            ctx.xxx.CollapseID = "TechnicalCollapse"
            ctx.xxx.CollapseImgClass = "Enlarge-shrinkIcon-Technical"
        _#-->
        _#= CoreRender(Srch.U.getRenderTemplateByName("~sitecollection/_catalogs/masterpage/Display Templates/xxx/Content/xxx_Control_List.js", ctx), ctx) =#_
    </div>
</body>
</html>
  • Do you Access the site using the same User? If you don´t, it might be, you just didn´t publish the new Display template (as Long it is in draft-status, it won´t be used/displayed for non-admin-users) – Leopold Lerch Dec 9 '15 at 9:15
  • I accessed it with the same user - with admin who has full permissions. The display template is published. I also repubished to major version, and even tried to delete it and check it in again. The strange thing is that it works from the server, but not from client. – Ilyas Dec 9 '15 at 9:23
  • I guess you already cleared the Cache from the Client? – Leopold Lerch Dec 9 '15 at 9:42
  • Is there anything in the code of the Display template, which simply may not be working on a Client machine? btw, is the code very big, can you post the Display template? – Leopold Lerch Dec 9 '15 at 9:44
  • Yes. That I have done also. This is making no sense to me why it is not working. I also checked to see if the file is ghosted, but it is not. I have completely run out of ideas – Ilyas Dec 9 '15 at 9:45
6

After banging my head around for some days, the problem was solved by flushing the blob cache.

This is the command I used on the Front end server

$webApp = Get-SPWebApplication "<WebApplicationURL>"

[Microsoft.SharePoint.Publishing.PublishingCache]::FlushBlobCache($webApp)

Write-Host "Flushed the BLOB cache for:" $webApp

https://technet.microsoft.com/en-us/library/gg277249.aspx

  • 4
    Could you explain how to flush the blob cache? It would help other people who run into this problem in the future. – wjervis Dec 9 '15 at 13:22
  • 3
    Done :). I edited the answer. – Ilyas Dec 9 '15 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.