1

When I want to create a SharePoint list from external content type on a client machine and when I click on "Select External Content Type", I am getting following error. The error does not happen, when I do the same operation on the server.

string or binary data would be truncated. The statement has been terminated at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsPArserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehaviour runBehavior,SqlCommand cndHandler, SQlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsPArserStateObject stateObj) at System.Data.SqlClient.SqlClient.SqlComand.RunExecuteNonQueryTds(string methodName, Boolean async) at System.Data.SqlClient.SqlClient.SqlComand.InternalExecuteNonQuery(DbAsyncResult result, string methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlClient.SqlComand.ExecuteNonQuery() at RedirectorModule.RedirectorModule.Application_BeginRequest(Object Source, EventArgs e)

Following is an extract from the logs

12/08/2015 18:50:04.56  w3wp.exe (xxxx) xxxxx   SharePoint Foundation   Topology    e5mc    Medium  WcfSendRequest: RemoteAddress: 'http://zxxxxxx:9999/GUID/MetadataWebService.svc' Channel: 'Microsoft.SharePoint.Taxonomy.IMetadataWebServiceApplication' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:xxxxxx'    
12/08/2015 18:50:07.29  w3wp.exe (xxxx) xxxx    SharePoint Foundation   Topology    xxxx    Medium  WcfReceiveRequest: LocalAddress: 'http://xxxxxxxx:9999/GUID/bdcservice.svc/http' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://www.microsoft.com/Office/2009/BusinessDataCatalog/BusinessDataCatalogSharedService/GetThrottlingRules' MessageId: 'urn:uuid:xxxxxx' xxxxxxx

I checked the secure store which I am using and the credentials, Everything seems to be working. It seems like an issue with BDC service app on this farm or something to do with connectivity to SQL server.

  • Created a seperated External content type and when I tried to create a "external list" in the site and click on "Select External Content Type" , I am getting the same error. – Nate Dec 9 '15 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.