1

My case is I have one web application which has only one site collection, for example, http://examplesite . This site collection has a content database, for example, wss_content. Then I created a new content database called wss_content_2015. I used 'move-spsite http://examplesite -DestinationDatabase WSS_Content_2015' to move from old to new content database. my questions are:

  1. Because I have only one site collection, therefor I expected the wss_content should be empty after I executed the command, but it turned out there is still one third of whole database left, why?

  2. if I upload the documents to the same url http://examplesite now, where these documents will be saved? in wss_content or wss_content_2015? is there a way which i can control how to save uploaded documents?

2
  1. when you move a site collection from one content database to other content database, it moved the site collection after that size of the source content db(wss_content) still be with same size, as that space showed as Unused(white space) in the content db. In that case you have to shrink the content database to get the space back.
  2. Now site collection moved to new content DB(WSS_Content_2015), so all the operation will be performed on this DB i.e upload the documents or creating sites etc.
4
  • But if I count the number of rows, they still return the same number, as below, the both return the same number, for example, 138749. why the old database still have these records. It isn't supposed to be moved to new one? or it is still the same reason I didn't the shrink the database, or something wrong with the command execution? SELECT COUNT(Id) FROM [WSS_Content_2015].[dbo].[AllDocs] SELECT COUNT(Id) FROM [WSS_Content].[dbo].[AllDocs] – XHM Dec 8 '15 at 19:17
  • where you are seeing the rows? run sp_spaceused against that content db in sql management studio – Waqas Sarwar MVP Dec 8 '15 at 19:18
  • Hi @Waqas Sarwar MCSE, Please see my updated comment, I ran the sql against AllDocs table in both databases, the returns are the same. It seems the command was copying them instead of moving, any ideas? I also run sp_spaceused and it confirm the old content database size has no changing at all. Do you know why? – XHM Dec 9 '15 at 15:29
  • hi, I figured out, i need to run ' Gradual site delete timer ' job in Central Admin, which will purge the database – XHM Dec 9 '15 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.