I've created a list with two columns. It contains Country Name (first column) and their 2 character abbreviation (second column).


Italy - IT

Sweden - SE

United Kingdom - UK

I've setup the list to sort on the column with the name "2 Characters".

Problem I experience, is that the list is not sorted correctly. There is a mix in the sorting. Like SE comes before IT.

What can be the cause to this?

enter image description here

Here is the settings for sorting the list for the view AllItems. enter image description here

  • 1
    Can you add screenshot ? Dec 8 '15 at 9:38
  • Which order did you choose? asc or desc? Dec 8 '15 at 9:41
  • Any help from my answer? @Andreas Dec 8 '15 at 20:16
  • Unfortunately I am not able to add a screenshot at this moment. Will get back when I am at that customer. I choose Asc order. Unfortunately your answer did not help.
    – Andreas
    Dec 9 '15 at 6:03
  • I guess the "2 character" column is the calculated column, and I think SP meet little trouble with sorting on calculated column.
    – trantab
    Dec 10 '15 at 9:02

Modify your view and choose

Show items in ascending order

(A, B, C, or 1, 2, 3)

enter image description here

Now SE should not come before IT, see my screenshot

enter image description here

  • I've set it up just like in your screenshot. Yet it does not sort correctly.
    – Andreas
    Dec 10 '15 at 7:05
  • Does SE contain any extra spaces ? Dec 10 '15 at 7:17
  • No, there are no extra spaces.
    – Andreas
    Dec 10 '15 at 20:05

Probably, you created/changed the view with sorting, but selected another view? If not, please, attach a screenshot of the view settings.

  • I've checked that as well, but nothing that indicates that it should be conflicting somewhere.
    – Andreas
    Dec 10 '15 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.