2

I'm using the SharePoint's OOTB Picture Library to store some pictures. I want to group the pictures by e.g. its "Created By" property (this could be a custom metadata property too).

The view with grouping works just fine, but once I hover over the items, they become selected. This varies whether the selecting by hovering happens on each group or for all but one group (usually the last group on the view). The items which are affected by this select by hovering -issue are also unclickable. Therefore they can't be opened just by clicking them (the ellipsis on the hover-pane do work). Then again the usually one group of items which work as intended can be opened by the default clicking.

Example of Picture Library

I've tried several views, different pictures, different grouping, different web applications, deactivating the "Allow individual item checkboxes" setting and pretty much anything related to the library's view options. The pictures and their opening behavior works without the grouping on the view.

Is this a general bug or am I missing something? Is there a rational explanation for this?

I'm running on SP2013 Server with December 2014 CU.

-1

I had the same problem. It seems to be an issue with the javascript on the page. Instead of trying to fix it, I worked around it by creating a view in SharePoint Designer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.