3

enter image description here

As per above image, I remove user from farm admin group,which assign in timer service account

But though it's fail to start "Timer service"

and another error regarding "SP timer service" is "missing server side dependencies" how to solve this?

1

The Farm Account, which is used for the SharePoint 2010 Timer service and the Central Administration site, is highly privileged and should not be used for other services on any computers in the server farm. Services in the farm were found to use this account.

Solution is simply create a new Domain account and set the permissions on the service database, then change the account from farm admin to New account.

The server farm account should not be used for other services (SharePoint Foundation 2010)

This is common error, if you dont want to create a new account, you can ignore this error.

  • because of this error my Timer service(SPTimerV4) Terminate unexpectedly, in every two minute @waqas – Amit Koyani Dec 8 '15 at 4:11
  • I don't think this health analyzer rule causing this...could you please check the event log for more error...under application and system – Waqas Sarwar MVP Dec 8 '15 at 4:13
  • There are two error are constantly throw 1)The SharePoint Timer Service service terminated with the following service-specific error: Unspecified error 2)The SharePoint Timer Service service terminated unexpectedly. It has done this 20 time(s).@Waqas – Amit Koyani Dec 8 '15 at 4:22
  • How many servers you have in farm? Is this happening on all servers? Any change to farm..any cu or updates? – Waqas Sarwar MVP Dec 8 '15 at 4:24
  • There is only one server,and no changes at farm level @Waqas – Amit Koyani Dec 8 '15 at 4:26
2

Here you find something about SP2010 which I think is also the right approach for SP2013: https://social.technet.microsoft.com/Forums/office/en-US/47954854-254f-4c72-8434-18a4072c952d/sharepoint-2010-health-analyzer-alerts-to-sptimerservice-sptimerv4?forum=sharepointadminprevious

Farm account need not be in local administrators group on any servers in sharepoint farm, from error message it looks like the farm account is member of admin group, another note timerservice needs to run under farm account

There is a bug in health analyzer alerts, it complains about User Profile Synchronization Service using farm account, user profile synchronization service must run under farm account and you should just ignore that alert

I installed with AutoSPInstaller and have also the same alerts. I just documented them and disabled the alearts.

  • My farm administration group have three account 1) admin 2) builtin\admin 3) domain\ABC and my local administration group have 1)administrator 2)domain\domain admins 3) domain\XYZ...is this configuration right? @Patrick – Amit Koyani Dec 7 '15 at 9:30
  • Actualy, the farm account needs to be in admins only while provisioning User Profile Synchronization Service. After that you can safely remove it from admins. – MikhailSP Dec 7 '15 at 15:04
  • I remove admin from farm administration group,but problem remain same @Patrick – Amit Koyani Dec 8 '15 at 5:12
0

It's cache.ini folder missing in Config folder my case, But while Create new cache.ini

for creating cache.ini following steps are given

Create cache.ini in folder 1) Select configuration database database 2) Run below query 3) SELECT Id FROM Objects WHERE Properties like '%SPConfigurationDatabase%'; 4) Make folder with this GUID in C:\ProgramData\Microsoft\SharePoint\Config Folder 5) Copy cache.ini in that folder OR create cache.ini 6) Delete all content in cache file and write 1 in them

But from that solution there is two, GUID found from the query Then, Out of two GUID,trial and error method try and solved,when correct GUID have found "Timer service" automatically started,and automatically generated XML file in GUID folder which found

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.