On several of my sites I have deployed some InfoPath Forms that have some custom code therein so they will save to their own libraries instead of to a form-submission library.

My problem is that when the user tries to print the forms only half of them will print. Everything shows fine in InfoPath's Print Preview mode, but then it doesn't show in Firefox's print preview.

I do not have a code-signing certificate and am afraid to re-deploy the forms again since folks are filling them in at the moment; but I still have to print them in entirety.

Is there some way to fix this? Maybe I can override some css in the master page or something?

I tried putting this in my master page's css, but I'm not sure it's the right thing, and it doesn't seem to overwrite the original(in corev4.css) anyway:

@media print {
.ms-globallinks, .ms-siteaction, .ms-areaseparatorcorner, .ms-titlearealeft, .ms-searchform, .ms-banner, .ms-buttonheightwidth, .ms-areaseparatorright, .ms-titlearearight, .ms-rightareacell, .ms-leftareacell, .ms-areaseparatorleft {
    display: auto!important;


So I captured the form page using Firefox's Scrapbook and removed all the script so it would not be interfering. Now it's just html and css, but I can still only print half the form! Something is still hiding half the form from printing.


So I can't use javascript to fix this because js doesn't run in the infopath form when it displays in the browser.

3 Answers 3


I had this problem as well a few years ago, and found that setting all of the height of the textboxes in the view to a fixed height (and not auto) resolved the issue.

  • hmmm... do you happen to have a css code for that? It would sure help! I'm not sure how to go about that.
    – bgmCoder
    Commented Dec 3, 2015 at 18:00
  • Nope.. no CSS code for it. I had to go into InfoPath Designer and set all the fields manually. Commented Dec 3, 2015 at 18:02
  • Awwwww! That's the problem. I don't think I can re-deploy the form or I will break it. I don't have a code-signing certificate.
    – bgmCoder
    Commented Dec 3, 2015 at 18:04

Well, I just spent the last 4 or 5 hours trying to fix this via css and couldn't solve it. I tried fixing it via js, but realized it is InfoPath, and you can't use js in InfoPath pages - even if you put the script in the Master Page.

I'm not sure what's the matter with the form; half of it prints via Firefox, but I have two other forms that print just fine from Firefox.

In the end I tried to print the forms using Internet Explorer instead of Firefox and it printed fine.


If your users have InfoPath Form Filler 2013 installed, I have a method that will work.

With the page open in designer, move your cursor to the top left corner of the form and single click. You should see a grey box. Click that grey box. This will highlight the whole page.

On the page design tab of the ribbon, click PAGE SETUP. This will pop up a menu. Click the PAGE SET UP tab. You should have a printer option. If you have Adobe PDF as a choice, select it and then click properties.

From the new pop up click the PAPER/QUALITY tab. Click the ADVANCED button a new window pops up. Find scaling and lower it to around 60%. You may need to come back and increase or decrease it. Click OK, OK, OK. YOU HAVE TO REPEAT FOR EACH PAGE IN THE FORM.

To test, preview your form, click file, print, print preview. It should automatically default to a PDF. NOTE: Mine only showed page one. Close the print preview. Try it from your actual form published in a library and print it to the PDF printer. You can then print that from ADOBE to a real printer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.