0

My Sharepoint Server is configured to use a local SMTP Server (the server's own IIS 6.0 SMTP virtual server). The problem with this is that the message headers of these emails don't receive the reverse DNS information, but I actually have a real mail server running (hMailServer) and I'd rather use that for smtp, or maybe even gmail.

How can I configure my Portal's outgoing email to use an external smtp server? I could set a different Outbound SMTP Server in SCA's Outgoing Email Settings, but there is nowhere to specify the login password for that server.

Or is there a way to make the local SMTP Virtual Server (in IIS6) to use my real mail server for SMTP?

  • 1
    This post describes setting up relay to external SMTP server from the default SMTP server on SP server, but I am not sure if this will provide the reverse DNS info u are looking for: blogs.technet.com/b/yashgoel-msft/archive/2012/10/26/… – Prakash - Crow Canyon Nov 30 '15 at 21:27
  • Thanks! Actually, I was just looking at that page... And I found I already had it configured, but had not set the FQDN correctly, nor added a masquerade domain... – bgmCoder Nov 30 '15 at 21:38
1

This post describes setting up relay to external SMTP server from the default SMTP server (on SharePoint server). Authentication information can be provided while setting up the outbound security:

http://blogs.technet.com/b/yashgoel-msft/archive/2012/10/26/configuring-outgoing-email-settings-in-sharepoint-with-gmail-smtp.aspx

Thanks

  • I found it was necessary to set the FQDN in both IIS6 settings AND in SCA's Outgoing Email Settings. This prevents email servers like google from seeing a mismatch in the domain/sender email headers. – bgmCoder Nov 30 '15 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.