I have a customized approval workflow. Myself and other Site Collection administrators can view the approval form just fine. When someone who is not a site collection administrator tries to view the approval form in a browser, they get a generic error and the correlation id provided cannot be found in the SharePoint logs.

I also tried elevating privileges, but even having full control does not help. People currently have contribute and approve.

The approval form has not been customized and users can use the approval form from outlook. They cannot go to their tasks and view the form in a browser.

EDIT: If I add a user to Home Owner group, then they can see the approval form. This is NOT ideal. What is unique about this group that allows them to see the approval form and not everyone else?

  • Did you ever sort this out? I'm having the same issue Commented Mar 13, 2012 at 5:29

3 Answers 3


I ended up fixing mine, by going back, disabling the workflows in the site collection, removing out the Basic Approval in SPD, then re-enabling workflows on the site collection. This recreated the workflow, and has been fine ever since.

  • I am getting the same error, but i am not able to understand the solution can you please elaborate a bit more?
    – user8579
    Commented May 29, 2012 at 11:38

Open the site in sharepoint designer, open the "All files" folder and browser to "Workflows" folder and find the one in question. Check if the approval.xsn is checked out, if it the approval file is checked out, check it in using powershell.

  • It is checked in
    – caschw
    Commented Jul 19, 2011 at 15:50

I came here with the identical symptoms described in the question. This is what solved it for me:

In the list that generates the task (So the one the approval workflow is triggered from) --> List Settings --> Advanced Settings: Under Item-level permissions --> Read access ensure that Read all items is selected. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.