I have SharePoint Server 2010 trial version installed on a server. Recently, I installed updates for SharePoint and these updates caused problems in my web application and site collections.

I couldn't get rid of the problems so I removed SharePoint using an uninstaller tool + manual methods because the normal setup file was corrupt and didn't work no matter what I tried. I removed all sites, databases and files. I also made sure the Registry is clean.

Of course that was a wrong move. Now, when I try to reinstall SharePoint Server 2010, I get a message that says: trial editions and licensed editions of sharepoint cannot be installed on the same server.

So I'd be so grateful if someone would suggest any solution to overcome this problem. I don't want to format the server just because of this issue.

Thank you!


4 Answers 4


I would load up Process Monitor http://live.sysinternals.com/Procmon.exe

then attempt your re-install again. You should be able to see what files/registry keys it is looking at, and remove or edit the offending entries from there.

If it starts to look like you will be spending more than an hour on it, then I would look to just re-install, it will take the same amount of time. I typically use VM's for testing / devs so I can rollback changes. If you are doing this on bare metal I would look at getting a tool like Acronis to create disk images in the future.

  • I decided to follow your good advice and use VM for testing and development. It was a mistake to not use that method from the beginning. Thank you! :) Commented Jul 19, 2011 at 8:53
  • 1
    Another good idea from you helped me solve the problem. Using the Process Monitor I found the registry key that I needed to delete. Once I deleted it, the installation asked me to re-enter the product key and it worked! Thanks Jesus for the good advice. :) Commented Jul 20, 2011 at 10:45

I used the Process Monitor as suggested by Jesus Shelby and it helped me identify the registry key I needed to delete.

I deleted the following registry entries:



After I deleted these two entries, the setup asked me to enter the product key. Although, the trial product key didn't work, I entered my company's product key and it worked!

Thanks to Jesus Shelby for his good advice.

Edit by Jan Steenbeek:

Just to confirm; this still works for SharePoint 2013 users running into the same problem!


The issue is due to Registry still keeping information about your trial version. I would go for re-install the trial version again and you could simply use the SP-CA to enter your new license (unless you want to either mess with registry or re-install your OS - which could also be an alternative to loosing time with Registry tweaking).

On the Central Administration Web site, in the Upgrade and Migration section, click Convert farm license type.

On the Convert License Type page, in the Enter the Product Key box, type the new product key and then click OK.


At one time, I had issue like yours. I though the Office products cause this issue and I checked in Control Panel. Then I deleted following products:

Microsoft Office Professional Plus 2010.
Microsoft Project Professional 2010
Microsoft Visio Premium 2010
SQL Server Reporting Service for SharePoint add-in.
Microsoft SharePoint Designer 2010.

Then I reinstalled SharePoint Server 2010. It worked well.

I think this helps you.

  • I tried...I only had Visual Studio 2008 installed and I removed it but nothing has changed. The SQL server reporting tool is installed as a prerequisite software by SharePoint installer. Commented Jul 19, 2011 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.