0

I am trying to delete a web application in my SharePoint 2013 environment. The first attempt deleted the database, the application pool, the IIS site... But the I got an error saying

An object of the type Microsoft.SharePoint.Administration.SPIisWebsiteUnprovisioningJobDefinition named "Unprovisioning Webapplication" already exists under the parent Microsoft.SharePoint.Administration.SPWebService named "". Rename your object or delete the existing object.

So I deleted the corresponding jobs, as I have seen in other blogs and questions, and then tried to delete the web application once again. This time I get this error:

An object in the SharePoint administrative framework, "SPWebApplication Name=Webapplication", could not be deleted because other objects depend on it. Update all of these dependants to point to null or different objects and retry this operation. The dependant objects are as follows:

However, there are no dependencies being displayed in the message. The logs don't provide any information either.

UPDATE: This web application had 3 site collections on it:

/

/Sites/A

/Sites/B

Where the first and second site collections had 1 shared database, and the last one had a separate database. All site collections and all databases are deleted though.

  • Try to delete it using powershell. – Niranjan Kulkarni Nov 23 '15 at 14:55
  • How many web applications are there, in your central administration. – Niranjan Kulkarni Nov 23 '15 at 14:56
  • Powershell does not make it either. Same error. There are 8 web applications (including the one I need to delete) – garfield185 Nov 23 '15 at 14:57
  • I have also tried to create a new database, attach it to the web application and try again. Still no success – garfield185 Nov 23 '15 at 15:06
1

looks like you have some kind of solution deployed to this web app. you should check this

  • Go to Central Administration>Operations>Solution Management .Here you can check whether there are any solutions deployed on the web application. if there is any, please remove it from the web app.
  • from central admin check if there is any timer job running for the web app.
  • Restart the SharePoint timer services and sharepoint admin services on all servers.
  • Now try to remove it with powershell using -force switch.
  • It is a brand new web applications, no solutions deployed. Still, I will try it. – garfield185 Nov 23 '15 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.