1

I have a SharePoint web application with a default zone (window auth only) with a url http://internal.companysite.com and an extended zone (FBA only) with a url http://external.companysite.com. The later one is a public url for non-employees. When a external user (non-employee) subscribes for alerts, he/she gets the alert emails with internal urls (except for 'Mobile View' link). However the very first subscription confirmation email has proper internal urls embeded in it.

I have seen a couple of discussions on MSDN forums but none of them provide a useful suggestion.

MSDN - SharePoint Foundation 2013 AAM, alerts, URL in email alert

Alerts in Extended Web Application

I have seen few posts talking about changing default zone but in my case it is not possible.

1

it is by design, Alerts always use the default zone URL. In your case you have two zones, so what you are seeing it is expecting.

the solution you mentioned is the solution either customized it or enable both authentication in same zone( default).

Check this coding solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.