-1

The "User Profile Synchronization service" gets stuck on starting on every machine and server I ever use.

Is there any guide, that is not Harbar's and 200 pages long, on what can make this service a success ? And by success I mean start.

When it first gets stuck on starting, it will stay there. This has to be the worst service made in the history of mankind.

  • I figured out, that the User Profile Synchronization Service Account has to have local Admin rights. So put the account into the local Administrators group for the start. At least it was a problem in my environment – Patrick Nov 19 '15 at 15:05
  • By User Profile Synchronization Service Account, you mean the farm account ? – Ilyas Nov 19 '15 at 15:08
  • Central Administration -> Manage services on server -> Click on Start for User Profile Synchronization Service -> And there the Account you specify – Patrick Nov 19 '15 at 15:12
  • Yep, and this has to run under the farm administrator. Running this service as the farm administrator, and having the farm administrator in the local administrator group, does not start the service for me. – Ilyas Nov 19 '15 at 15:14
  • okay, well, you could give us more details about what you already tried and what the setup of your environment is... – Patrick Nov 19 '15 at 15:18
1

Try Patching your SharePoint servers. I am working on a project for a customer now and after we patched all of our SharePoint Servers to SP1 and November 2015 CU the service now starts without any issues.

You can find your servers patch level by going to: yourcentraladminaddress/_admin/PatchStatus.aspx

Macth your SharePoint Servers build numbers on this article: http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=346 to check if you have SP1 installed and what CU your servers are on.

2

that is really tough question to answer.

You have to check the ULS logs and Event Viewer during the time when it stuck.

I would do following things( i hate AutospInstaller)

  • Delete the User Profile service
  • check the Certs store on server, make sure no SharePoint/FIm certs over their, if any delete them.check this
  • check the central admin > monitoring and delete ProfileSynchronizationSetupJob job if running. it is one time job.
  • reboot the server
  • add the farm account into Local admin( as this will run the UPS sync).
  • recreate the User Profile Manually
  • Start the Sync service.
  • How can I check the cert store. Could you please clarify ? :) – Ilyas Nov 23 '15 at 16:32
  • 1
    link i mentioned in the answer will show you how to check the certs store. – Waqas Sarwar MVP Nov 23 '15 at 16:36
0

Your were looking at your answer. If you follow Harbars guide - it will work. He even has a "Stuck on Starting" page to help you troubleshoot. TechNet also has the step by step for deploying it - if you follow that, it will work (Mr. Harbar had input on that article as well).

if your permissions are not right, it won't work. You may also want to consider using something like AutoSPInstaller - to deploy your DEV box which helps with the setup (you still have some permissions to set outside that tool).

If all you need is a working environment I would consider rolling out a machine in Azure or using a service like CloudShare.

  • I used autopsinstaller. The service did not work, and after banging my head around and almost googling myself to death,I found an article which described that December 2014 CU could start the service, and it did. Then after some time some new updates where installed automatically, and after that it will not start. And believe me, I used technet and harbar, and tried all the tricks. This service is so poor and weak that it needs an hot fix to work. – Ilyas Nov 19 '15 at 16:20
  • I used AutoSPInstaller with prereq $true, languagepack and the CU (October 2015). After the Install I configured in Central Administration the Synchronization Connections and it worked out of the box. @Waqas (I love AutoSPInstaller) :) – Patrick Nov 20 '15 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.