1

In my SharePoint farm I have default AD authentication and SAML Claim based authentication. I am unable to see the profile of other users, when I click on the user's name from any site collection. i.e if I go to any SP group and click on any user , the _layouts/15/userdisp.aspx is throwing below error:

Microsoft.Office.Server.UserProfiles.UserNotFoundException: An error was encountered while retrieving the user profile. 
at Microsoft.Office.Server.UserProfiles.UserProfileCache.GetUserData(UserProfileManager objManager, Nullable`1 recordId, Guid gAcct, String strAcct, Byte[] bSid, String strEmail, Boolean doNotResolveToMasterAccount) 
at Microsoft.Office.Server.UserProfiles.UserProfile.RetrieveUser(String strAcct, Guid gAcct, Byte[] bSid, Nullable`1 recordId, Boolean doNotResolveToMasterAccount, Boolean loadFullProfile, Boolean loadColleagueRecordIds, String strEmail)
at Microsoft.Office.Server.UserProfiles.UserProfile..ctor(UserProfileManager objManager, String strAcct, Boolean doNotResolveToMasterAccount, Boolean forceUserIsSelf, Boolean loadFullProfile, Boolean loadColleagueRecordIds, String strEmail)
at Microsoft.Office.Server.UserProfiles.UserProfileManager.GetUserProfile(String strAccountName, Boolean doNotResolveToMasterAccount, Boolean loadFullProfile, Boolean loadColleagueRecordIds)
at Microsoft.Office.Server.UserProfiles.UserProfileManager.GetUserProfile(String strAccountName, Boolean doNotResolveToMasterAccount)
at Microsoft.Office.Server.UserProfiles.UserProfileManager.GetUserProfile(String strAccountName)
at Microsoft.SharePoint.Portal.WebControls.MySiteRedirectionUserControl.RedirectIfNecessary(SPListItem user)
at Microsoft.SharePoint.Portal.WebControls.MySiteRedirectionUserControl.OnFormInit(Object objOfInterest)
at Microsoft.SharePoint.WebControls.DelegateControl.CallFormInitForChildren(Object objOfInterest)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Troubleshooting done so far:

  1. The user profile is existing for the users and I can retrieve their values using powershell.
  2. I tried to retrieve values using SSOM in console i got the same error.

  3. The issue is occurring only for SAML auth users and for windows AD users it is working perfectly (ie if user profile exists redirected to profile page otherwise shows user information list data in the page itself)

**

Update: September 2015 CU is Evil!

We had to open a Microsoft ticket for this. This bug was introduced after September 2015 CU was installed and MS acknowledged it. Microsoft did not release any hotfix , but informed that this will be fixed in February 2016 CU. I have not yet installed Feb CU , I will update here, if this gets fixed in Feb 2016 CU.

Update

I have applied Feb CU update and this issue is fixed in that CU.

1

I confirm that the installation of February 2016 CU for SharePoint Server 2013, solves the issue, I've just finished testing: February 9, 2016, update for SharePoint Server 2013 (KB3054818) https://support.microsoft.com/en-us/kb/3114726

Improvements and fixes After you migrate from classic-mode to claims-based authentication in SharePoint Server 2013, you can't access the Author property for a document. Instead, you receive a "User Not Found" exception message.

Regards, Dan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.