0

In a SP2013 environment I am experiencing difficulties with crawling some, but not all RTF files.

I am aware that SP2013 will not crawl .rtf files out-of-the box so to accommodate this I have done the following:

  • Registered the iFilter with the regsvr32 command at command prompt by placing the following line in command prompt: regsvr32 rtffilt.dll (checked if the RTF iFilter was on the search server. It is called rtffilt.dll and lies in the %windir%\system32 folder)
  • Added the file type to the managed file types page in central administration
  • Restarted the SharePoint Server Search 15 service from services.msc
  • Ran a full crawl

After this I saw that RTF files started appearing when I searched for content within these files. However, it seems to not index all the files - only some. More detailed:

  • The files that the crawler doesn't find lies within the same document library as the ones it does find.
  • The documents which it doesn't find is not checked out and major version (1.0) is published.
  • I have attempted an index reset and full crawl, which didn't help.

Also: when I am inside farm search administration through CA (http://<centraladmin>:<port>/_admin/search/CrawlLogURLExplorer.aspx) and attempt to look up the documents I am missing, I find nothing. No error or message of successful crawl or anything. The files don't appear to be corrupted in any manner and opens fine in text editor.

Why would the search service in Sharepoint not pick up these files, when it works for some?

  • Have you already tried searching without the 'automatically remove duplicates' option? I have seen word documents dissapear because It was recognized as a duplicate. Although I would expect them to show in CA. – Wout Nov 19 '15 at 21:49
  • files are checked-in, published and approved? What if you re-index the list? (list settings -> advanced properties) – Wout Nov 19 '15 at 21:51
  • I have tried the remove duplicates option in the search webpart, but still nothing appears. Could there be a 'automatically remove duplicates' option in the farm search settings also (I can't recall seeing one), and not just in the search webparts? Files are checked-in, published and approved. I can attempt a re-indexing of the list later today (I'd rather not do it during work hours as this is a production environment) – user3463093 Nov 20 '15 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.