I have migrated to Sharepoint 2010 successfully but Search service wasn't working every time I get system error when I perform search.

Today I have tried following things on server,

1] Application Management -> Manage Service Application -> Search Service application was present so I have added new "User Profile Service Application". Added spservice account, superuseraccount & superreaderaccount, "Network Service" access to "Full Control". (http://blog.concurrency.com/sharepoint/search-configuration-in-sharepoint-2010/ followed steps 8 to 12)

2] Added above user to intranet site (root:80) under user policy (Application Management -> Manage Web application -> intranet site (root:80) -> User Policy)

3] Then ran following command from command prompt stsadm -o setproperty -pn portalsuperuseraccount -pv pro1766\sp_superuser_cache -url http://intranet.mysite .com stsadm -o setproperty -pn portalsuperreaderaccount -pv pro1766\sp_superreader_cache -url http://intranet.mysite.com and restarted IIS.

4] On main site started showing Access denied error

hence reverted all the above changes,

5] Deleted "User Profile Service Application" from Application Management -> Manage Service Application 6] Remove user from user policy (Application Management -> Manage Web application -> intranet site (root:80) -> User Policy) 7] restarted IIS

8] Now there is new error is coming on server and whole site is not working. Everyone is getting Access denied error

PortalSiteMapProvider was unable to fetch current node, request URL: /default.aspx, message: Thread was being aborted., stack trace: at System.Threading.Thread.AbortInternal() at System.Threading.Thread.Abort(Object stateInfo) at System.Web.HttpResponse.End() at Microsoft.SharePoint.Utilities.SPUtility.Redirect(String url, SPRedirectFlags flags, HttpContext context, String queryString) at Microsoft.SharePoint.Utilities.SPUtility.RedirectToAccessDeniedPage(HttpContext context) at Microsoft.SharePoint.Utilities.SPUtility.HandleAccessDenied(HttpContext context) at Microsoft.SharePoint.Utilities.SPUtility.HandleAccessDenied(Exception ex) at Microsoft.SharePoint.Library.SPRequest.GetWebMetainfo(String bstrUrl) at Microsoft.SharePoint.SPWeb.get_AllProperties() ... f9307557-b538-4cb7-881f-473845360845 at Microsoft.SharePoint.Publishing.SiteCacheSettings..ctor(SPSite site) at Microsoft.SharePoint.Publishing.SiteCacheSettings.GetSiteCacheSettings(CacheManager cacheManager) at Microsoft.SharePoint.Publishing.CacheManager..ctor(SPSite site) at Microsoft.SharePoint.Publishing.CacheManager.GetManager(SPSite site, Boolean useContextSite, Boolean allowContextSiteOptimization) at Microsoft.SharePoint.Publishing.Navigation.PortalSiteMapProvider.get_ObjectFactory() at Microsoft.SharePoint.Publishing.Navigation.PortalSiteMapProvider.get_CurrentNode() f9307557-b538-4cb7-881f-473845360845

Can someone please let me know what to do next?

2 Answers 2


I have fixed the issue by running Powershell command and site is working fine now.

$wa = Get-SPWebApplication -Identity "http://intranet.mysite.com" $wa.Properties[" portalsuperuseraccount"] = "i:0#.w|pro1766\sp_superuser_cache" $wa.Properties["portalsuperreaderaccount"] = "i:0#.w|pro1766\sp_superreader_cache" $wa.Update()

  • 1
    Claims authentication 'claims' another victim (see what I did there?) :)
    – James Love
    Jul 18, 2011 at 7:18
  • Had exact same issue of adding object cache accounts to a SharePoint site with ADFS 2.0 claims. Used AD names rather then "ADFS path" just like you did and got same error. Your solution of changing accounts to their ADFS friendly versions solved it for me as well after a iisreset. Thanks. Jul 3, 2012 at 20:17

Are there no corresponding errors with the ULS or system logs? Check your security logs, and verify none of the service accounts are experiancing issues. If they are, the type of issue should be included with the failed logon attempt. Your logs should give you more informiaton to go on.

Have you re-run psconfig?

I would recomend doing a configuration backup at minimum (if not a farm backup) prior to making changes like these, so you can easily roll back to your working configuration.

  • I am answering to my question below. Thanks for your help!
    – neo269
    Jul 17, 2011 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.