1

I have a web (the root web) where the Publishing Infrastructure Feature is activated on site level and inside the same web (root web of site collection) the Publishing Web Feature is also activated. There is "Pages" library with a default.aspx in it and the web is using it as welcome page (and it can be access without problems).

But somehow the Publishing Web Feature is broken. On default.aspx (or any other page inside that web) I don't have the "Page Layout" option in the ribbon - it is the normal ribbon that non publishing pages normally use. Other webs in the same site collection behave normally and a page layout it selectable.

I tried deactivating the Publishing Web Feature and reactivating it (with force) but this doesn't help. Well it only helps if I also delete the "Pages" library first and then reactivate the feature so that the library is created completely new (but this time as "Seiten" (german)). But then I would lose some important pages inside the library.

So something is currently missing which is correctly set inside the newly created library or is happening inside the feature activation but I don't know what it is. Maybe it has something to do with the language/localization as the new library gets a different name.

The properties PagesListId, PagesListName and PagesList are correctly set.

Any ideas?

  • Just wondering, did you create the site from a 'template'? (save web as template...) – Wout Nov 18 '15 at 14:12
  • Honestly I don't know who initially created the site. But as it is the root site I don't think it was created by using "Save as a template". I think it is still the same site that was deployed as root web during site collection creation and I guess the "Publishing Page" template has been used. – Shihan Nov 18 '15 at 14:29
  • FWIW.....to piggy back off of @W0ut comment, when standing up a 2013 farm, we created a template and pushed the template using PowerShell to mirror our 2007 farm. One thing we ran into for sites based off of the template, was that Change the Look had no options. We had to go into Composed Looks, create a Data view and change the URLs from a relative path to an absolute path for that site. – David Jenkins Nov 18 '15 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.