I have a designer workflow that triggers an email on item creation. However, body of the email should contain one of the field value. This field is of type multiple lines of text, plain text and appends changes checked.

I am receiving an email but it shows blank for multiple lines of text. Can't, we show Multiple lines of text field value in designer email, is it unsupported?enter image description here

Update : When I disable append changes, it works fine for me. But we need append changes also if I run it manually it works fine. Just not working on Item Added event.

Update 2 Adding pause of 5 min didn't help as well.

5 Answers 5


The reason it doesn't work with 'append changes' is because each comment change is saved as a version of the item - the actual field in the current version is always blank. I supposed there's some way in a 2013 workflow to use the http calls to grab all versions and rebuild the comment, but that would be a lot of work for little gain. Your workaround is the best.


It is well supported you can send email that contain richtext field value in body of email. I have recently done the same thing with the combination you mention above and its working.

  • are you sure it works with append changes, on Item added event? When I disable append changes, it works fine for me as well. But we need append changes.
    – Rohit
    Commented Nov 18, 2015 at 11:00
  • 1
    Yeah :( i was bit in hurry to comment, I did a work around to achieve the functionality. I had created a new column which will store the complete history of the comments(in your case title issue desc) . before send email , i get the current item text and append (update) the history column and use this history column in the body of the email.
    – Ravindra
    Commented Nov 18, 2015 at 11:17

Try assigning the multiple lines of text field to a string variable in the workflow and use that in the email body instead of the original field.


i was able to use this workaround, since my users enter comments via tasks assigned to them:

-disabled 'append changes' in the item comment field

-implemented the append in the workflow (append task comments to current item comments)

-i can now include the comments in logs, mails, ... in the workflow


I found what Microsoft says about it: Workflow that uses the SharePoint 2013 Workflow Platform Type contains blank values in output from the "Multiple lines of text" column


To work around this issue, disable automatic updating of the workflow status to the current stage name. To do this, follow these steps:

  1. Open the affected workflow in Microsoft SharePoint Designer 2013.
  2. On the Workflow Settings page for the workflow, clear the Automatically update the workflow status to the current stage name check box.
  3. Save the workflow, and then and publish it to the SharePoint website.
  4. Run the workflow again.


  • When you clear this setting, you may want to use the Set Workflow Status action as part of the workflow to update the Workflow Status field if that appears to be necessary. Otherwise, the status won't be listed.
  • You may also want to consider saving the value of the Multiple lines of text column in a workflow variable if you plan to update the list item within the workflow logic.
  • In this scenario, the value from the Multiple Lines of text column will be blank if you edit the list item but don't change the Multiple Lines of Text column.
  • You need to provide details of your answer and not just link to another site. Commented Aug 29, 2018 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.