1

I am having some problems creating and editing documents on a SharePoint 2013 site on a upgraded Mac (El Capitan) and with Office 2016. When I try to create a new document, or edit, I get the notification that “The document could not be opened for editing. A Microsoft SharePoint Foundation compatible application could not be found to edit the document “.

I have tried reinstall Office.

Googled and found out that Office 2016 for Mac may not have the SharePointBrowserPlugin and SharePointWebKitPlugin. So I tried copying the files from a Office 2011 for Mac. But still not working.

When I check Safari Security Plugin setting I can see that SharePoint Browser Plugin is listed and given the permission “Allow” for the SharePoint site (regardless Office 2011 or 2016).

I also checked for the plugin files with a new Office 2016 installation, and apparently they are there.

Note: When I only have Office 2011 installed, all works fine! and I can create/edit a new file and it opens in Word!

UPDATE:

If I have Office 2011 and 2016 installed, I get the properties when only 2011 was installed. So now, I can create a new document (from content type) or edit it, and when the document opens, it opens in Word 2016!

However, this should not be necessary and a fix should come from Apple and/or Microsoft.

Nevertheless, if someone knows a workaround or a fix so that only Office 2016 needs to be installed, I still want to know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.