I currently have a quite a simple workflow on a library that has a simple content type. I have created a SharePont Designer 2010 workflow that updateds a list item value based on whether or not the customer is new or existing. The content type has a word file that is the basis of the template that is to be used for this process.

The issue is that the I continue to get this error when the update is attempting to be complete. "The item is currently locked for editing. Waiting for item to be checked in or for the lock to be released."

The thing I am puzzled on is that when I use the add new document option from the library, I have success and the workflow works. What is causing this with using a content type with a word document.

  • i wanted to mention that I have this set to automatically launch when an item is created. I just tried launching manually and this seems to work when I manually trigger the workflow from the item. Jul 15, 2011 at 19:15

2 Answers 2


It is a little hokey, but try putting in a short delay at the beginning of the workflow, to give the system a chance to clear the lock (if it is system generated). See if waiting for 30 seconds, etc., makes a difference.

  • Chris, this worked. The only issue I have now is that it seems as though SP Designer doesn't offer a second(s) interval for a delay. I can do one minute but need a shorter duration. Thoughts? Aug 8, 2011 at 17:25

Paul Akerlind

This is a common problem in Infopath and sharepoint integration. The reason is when you submit a form from a client machine using data connection. the Infopath editor holds the Form library for a while. this is the reason that you got the below message.

"The item is currently locked for editing. Waiting for item to be checked in or for the lock to be released."

Now the solution is very simple All you need to do, Add an Action

"Wait for document to be Unlocked by document editor". Then add your remaining Actions in the workflow as per your logic.

I am sure this will solve your problem. please let me know if you need furhter help.


  • Remove all the Instances of the workflow & then publish it again. The problem will be solved...!! Thanks
    – Kishan
    Apr 3, 2012 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.