0

In our SharePoint 2013 (Enterprise version) based intranet production farm, after SharePoint server reboot, the 'SharePoint Search Host Controller' service(in services.msc window) is not running and stucks on starting.

Search functionality i snow not working as this service is not running.

This service was running before and search was also working OK but after server reboot this service has stopped to run. In central admin -> services this service shows as started but in 'Windows Services' it is not running.

In event viewer there are following error messages continuously reported.

Event 1000-Faulting application name:hostcontrollerservice.exe

Event 1026-Application:hostcontrollersesrvice.exe,Exception info:System.ServiceModel.AddressAlreadyInUseException.

I have tried following solutions so far to start this service but no joy.

  • Cleared the cache from config folder and modified Cache.ini file
  • Elevated the search account permission on all search related databases, added search account to local admin group as well.

SharePoint Search Host Controller service and SharePoint Server Search15 service both are using the same logon identity account.

0

Can you check if the following windows services are running correctly

Remote Registry Appfabric Caching Service (and if this is configured correctly) Net. Tcp Port Sharing Service Net. Tcp Listener Adapter

  • All these 4 services are running fine, SharePoint log file contains this following exception details for hostcontroller service. 11/17/2015 12:14:56.59 hostcontrollerservice.exe (0x408C) 0x40F4 Search Search HostController ad5eq Unexpected WcfService: Exception during service start - threadId: 12 - exception: System.ServiceModel.AddressAlreadyInUseException: The TransportManager failed to listen on the supplied URI using the NetTcpPortSharing service: the service failed to listen. at System.ServiceModel.Channels.SharedConnectionListener.SharedListenerProxy.Register() at – Hina Thakkar Nov 17 '15 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.