I have installed SharePoint 2010 SP1 on my local developer machine.

I wanted to copy a site collection from one of our productive servers (which hasn't SP1 yet but the December 2010 Cumulative Update) to my dev machine so I could develop locally on it. So I made a backup on the server with stsadm -o backup ....

When I tried to restore it back on my machine with stsadm -o restore ... it brought the following error:

Your backup is from a different version of Microsoft SharePoint Foundation and c annot be restored to a server running the current version. The backup file shoul d be restored to a server with version '' or later.

Why is that? I know that I have a different (newer) version locally. But it says "or later" so isn't it suppose to work this way? I could understand it when it was the other way around (restoring backup from a newer version on an older SharePoint) but so it makes no sense.

Shouldn't that be possible or am I doing something wrong?

3 Answers 3


Are you able to take a backup of the content database that holds the site collection? If you do so you can then restore the SQL Content DB to your dev sql instance and attach it to a development web application, the attach will perform an 'upgrade' on the content db and should take care of your issue.

  • I know that this would work but my question is more in the direction why it isn't working the way it should.
    – Shihan
    Commented Jul 15, 2011 at 13:47
  • STSADM Backup/Restore requires that both farms be on the same build version. I believe that both SQL instances also have to have the same version. I've seen this documented in the past but can't seem to find the sources now. However, doing the content database attach will effectively upgrade your content DB to the build on your Dev environment. Hope this helps. Commented Jul 15, 2011 at 13:58
  • Do the restore on a pre-SP1 install of SharePoint and then apply service pack 1. Alternately, apply Service Pack 1 to a DEV server where the site collection currently resides and take a backup.
    – 78lro
    Commented Jun 12, 2012 at 14:32

I had the same issue of actually restoring the Site Collection on a different server that had a patch different than my server. And the DB restore also did not work because my SQL version were different. So, I basically downloaded the SQL Express same version as my other machine and then restored the DB. Then I actually upgraded my test server to the same version as my other machine and was able to successfully able to restore the Content DB and the Site Collection.

Regards Vishwas


Although i would strongly recommend against this workaround that i tried, i was able to restore my backup which had failed this version check.

Open your *.bak file or the backup file in VS2013...It might take a while to open...If you have a good disassembler or one of those good old days tools used by s/w cr**kers, you can use them to edit the file. Ignore all the hex codes. At the start of the file, you can see the file version. Change it to the version of your server, save it and try the stsadm command once again.

enter image description here

There are few points to be noted for this approach:

  1. Ensure that the backup file size is smaller (preferably less than 500MB), else you might need a good editor (Visual Studio 2013 would crash beyond 500MB)
  2. Keep note of the version number of the SharePoint Configuration Database Schema of the server to which you wish to restore the backup - Check the ULS logs for the actual exception message. You will get the expected version number here.
  3. Ensure that there are no major version differences in between the environment version. You can analyze this by going through the release notes of the higher version and see if there are no DB schema changes. Security updates/minor patches should be fine. But if you see any major DB schema changes in the release notes, please avoid this fix.
  4. Please take a backup of the backup file before you proceed.

A gist of few other fixes can be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.