When I click on the "Sites" link (see screenshot) on a Mysite page , it is not opened, instead it redirects to home page newsfeed.

enter image description hereenter image description here

  • Reset your IIS and then try again. Nov 17, 2015 at 8:36

1 Answer 1


the message on the page showing, sharepoint is creating your Mysite. "we are almost ready!" is the message you get 1st time. But if you and all other user getting this error all the time then you have to make sure following things.

  • configured My site url correctly in user profile service application
  • Created a wild card managed path for My sites
  • Given a permission to user to create self-service site on your my-site web application.
  • Make Sure Self-Service Site Creation enabled on the MySite web app.
  • Distributed Cache is up and running.


  • iam checked but its still not working , same page opened
    – kumar
    Nov 20, 2015 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.