Here is the setup

  • SharePoint 2010
  • BDC application definition
  • Search Content Source of type Line of Business that crawls the BDC

Steps taken

  1. Import BDC application definition version
  2. Create content source for the BDC
  3. Full crawl content source
  4. View crawl logs shows 1000 successes
  5. Import updated BDC application definition version
  6. Full crawl content source
  7. View crawl logs shows 1000 successes and 1000 errors

The errors are all the same:

Error while crawling LOB contents. ( IEntity could not be found using criteria 'Id=5521'. )

Using Powershell Get-SPBusinessDataCatalogMetadataObject I can see that Id=5521 is the Id of the Entity in the BDC version

I can see by the Id in the crawl logs the successes are all for the updated Entity in the BDC version

I've tried full crawling the content source many times and the errors never go away. The only way I can find to get rid of them is to delete the content source and re-create it.

Why is this happening? Is there a better way to fix this than deleteing the content source?

1 Answer 1


I have run into this problem as well. What i found helped is that if i had external lists generated, i had to re-generate them, then crawl again. Not sure why it worked but it seemed to.

  • Yep we had this too - the search is crawling the external lists which are trying to point to the original BDC. Unfortunately you have to recreate the external lists. :(
    – Russell
    Dec 22, 2011 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.