2

I'm trying to deploy a simple remote event receiver (as per http://sundarnarasiman.net/?p=224) to a hosted Sharepoint 2013 server, for which I have admin rights.

However, when building/deploying this in VS2013, I get the error:

The HTTP service located at http://[host_address]:32843/0dcd895ab64d4fd49f04b6368234be82/AppMng.svc is unavailable. This could be because the service is too busy or because no endpoint was found listening at the specified address. Please ensure that the address is correct and try accessing the service again later.

Navigating to the given Site Contents page, the app exists but is greyed out as unavailable.

Is there some kind of security setting that I am missing?

  • Did you provision the App Management Service Application in Manage Service Applications and start the App Management Service in Manage Services on Server? This is done via Central Admin. – Trevor Seward Nov 11 '15 at 15:31
  • No, I'm not sure what you mean here, what does this entail? – bak202 Nov 11 '15 at 15:53
  • The Service must be started and the Service Application must be created in Central Administration. Go to Central Administration -> System Settings -> Manage Services on Server to start the App Management Service. Go to Central Admin -> Application Management -> Manage Service Applications, New menu, and create an App Management Service. – Trevor Seward Nov 11 '15 at 16:01
  • Thanks. Yes there already seems to be an App Management Service running - where the services' database name is AppMng_Service_DB_2c847499dd0a4a12aa8367e18ae2e062. – bak202 Nov 11 '15 at 16:20
  • Next step would be to make sure the IIS Application Pool is running in the IIS Manager. The App Pool will have a random GUID identifier (without the dashes). – Trevor Seward Nov 11 '15 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.